sabato 12 novembre 2011

Nuovi aggiornamenti di sicurezza per Ubuntu 11.10 Oneiric Ocelot.

Maria Susana Diaz | 19:30 |
Sappiamo tutti quanto sia importante mantenere aggiornato il proprio sistema operativo, ma è parimenti esperienza comune che spesso siano proprio gli aggiornamenti a introdurre nuovi bug. Ubuntu segue delle linee guida ben precise per gestire questa situazione.

La chiave di volta dell’intero discorso è che, una volta rilasciata la release, gli aggiornamenti non si fanno affatto, a meno che non riguardino vulnerabilità di sicurezza o bug particolarmente significativi.

Addirittura, nell’ottica di stabilizzare la release, già durante le ultime fasi di sviluppo l’ingresso di nuovi pacchetti dei vari software è sottoposto ad un controllo particolarmente rigido (una fase nota agli sviluppatori come “Feature Freeze”, appunto).

Gli aggiornamenti proposti a continuazione fanno parte del bollettino di sicurezza settimanale rilasciato da Canonical e riguardano in particolare:
  • The GNU assembler linker and binary utilities.
  • Evolution databases backend server.
  • Gnome. Graphics Viewer.
  • Python modules for printer configuration for CUPS.
  • Adobe Flash Player Plugin downloader.
  • Adobe Flash Player plugin.
  • The GNU assembler linker and binary utilities.
  • Ubuntu Desktop Guide.

Eye of Gnome Graphics viewer program.
 
Modifiche per le versioni:
Versione installata: 3.2.0-0ubuntu1
Versione disponibile: 3.2.1-0ubuntu1

Versione 3.2.1-0ubuntu1:

  [ Chase Douglas ]
  * Update Bzr-Vcs tag to point to ~ubuntu-desktop instead of ~gnome3-team

  [ Didier Roche ]
  * New upstream release (LP: #877186)
    - new and updated translations

eog or the Eye of GNOME is a simple graphics viewer for the GNOME desktop which uses the gdk-pixbuf library.
It can deal with large images, and zoom and scroll with constant memory usage.
Its goals are simplicity and standards compliance.


Python modules for printer configuration for CUPS.


Python modules for printer configuration with CUPS. The modules have no GUI and can therefore also be used on headless servers or by background processes.

Modifiche per le versioni:
Versione installata: 1.3.6+20110831-0ubuntu9.2
Versione disponibile: 1.3.6+20110831-0ubuntu9.3

Versione 1.3.6+20110831-0ubuntu9.3:

  * debian/patches/73_fix_file_descriptor_leak_in_ppdcache.patch: Fixed
    file descriptor leak in PPD cache (LP: #874445).

Adobe Flash Player Plugin downloader.
 
Modifiche per le versioni:
Versione installata: 11.0.1.152ubuntu1
Versione disponibile: 11.1.102.55ubuntu0.11.10.1

Versione 11.1.102.55ubuntu0.11.10.1:

  * New upstream release 11.1.102.55
    - debian/flashplugin-download.{config,postinst}: Updated sha256sums and
      version.
    - CVE-2011-2445
    - CVE-2011-2450
    - CVE-2011-2451
    - CVE-2011-2452
    - CVE-2011-2453
    - CVE-2011-2454
    - CVE-2011-2455
    - CVE-2011-2456
    - CVE-2011-2457
    - CVE-2011-2458
    - CVE-2011-2459
    - CVE-2011-2460


Downloads and Installs the Adobe Flash Player plugin. The Adobe Flash Player plugin supports playing of media and other dynamic content online.
The Adobe Flash Player plugin will work with a range of web-browsers including, limited to:
* Firefox
* Chromium
* SeaMonkey
* Iceweasel
* Iceape
* Galeon
* Epiphany
* Konqueror WARNING: Installing this Ubuntu package causes the Adobe Flash Player plugin to be downloaded from the Canonical partner archive. The distribution license of the Adobe Flash Player plugin is available at www.adobe.com. Installing this Ubuntu package implies that you have accepted the terms of that license.

Adobe Flash Player plugin installer.

Modifiche per le versioni:
Versione installata: 11.0.1.152ubuntu1
Versione disponibile: 11.1.102.55ubuntu0.11.10.1

Versione 11.1.102.55ubuntu0.11.10.1:

  * New upstream release 11.1.102.55
    - debian/flashplugin-download.{config,postinst}: Updated sha256sums and
      version.
    - CVE-2011-2445
    - CVE-2011-2450
    - CVE-2011-2451
    - CVE-2011-2452
    - CVE-2011-2453
    - CVE-2011-2454
    - CVE-2011-2455
    - CVE-2011-2456
    - CVE-2011-2457
    - CVE-2011-2458
    - CVE-2011-2459
    - CVE-2011-2460


This is a metapackage that should be used on amd64 to properly install the nspluginwrapper dependency.

The GNU assembler linker and binary utilities.
 
The programs in this package are used to assemble, link and manipulate binary and object files.
They may be used in conjunction with a compiler and various libraries to build programs.


Modifiche per le versioni:
Versione installata: 2.21.53.20110810-0ubuntu4
Versione disponibile: 2.21.53.20110810-0ubuntu5

Versione 2.21.53.20110810-0ubuntu5:

  * Fix PR ld/13287, taken from the trunk. LP: #872687.

Evolution databases backend server.
 
Modifiche per le versioni:
Versione installata: 3.2.0-0ubuntu1
Versione disponibile: 3.2.1-0ubuntu1

Versione 3.2.1-0ubuntu1:

  * New upstream bugfix release. (LP: #876654)


The data server, called "Evolution Data Server" is responsible for managing mail, calendar, addressbook, tasks and memo information.

Ubuntu Desktop Guide.
 
This package holds the official Ubuntu-specific documentation, maintained by the Ubuntu Documentation Team. The documentation can be viewed using Yelp, the GNOME help browser.

Modifiche per le versioni:
Versione installata: 11.10.4
Versione disponibile: 11.10.5

Versione 11.10.5:

  [ Robert Roth ]
  * Punctuation and typo fixes, LP: #874754, LP: #876257, LP: #872204,
    LP: #872205
  * Fix System Settings sections for Time&Date and Language Support LP: #868153
  * Update instructions to starting CCSM (as it's not possible from
    System Settings anymore, the new instructions point to using the dash
    to start CCSM) LP: #869457
  [ Matthew East ]
  * Update translations from Launchpad 26.10.11




Ricerca personalizzata




Se ti è piaciuto l'articolo, iscriviti al feed per tenerti sempre aggiornato sui nuovi contenuti del blog:

GOOGLE+

LINKEDIN

Xtreme Download Manager, XDMAN Ubuntu, audio, Linux opera mini, browser internet Chromium Linux, Chrome, browsers tux collection, mascote Linux LibreCAD, Grafica, Disegno vim, editor, linux, ubuntu Ardour, audio, Ubuntu Unity, deskyop, Gnome, Ubuntu grafica 3d, Linux, Blender